О программе

Благодарим Вас за выбор программы WilDWooD Смета!

Надеемся, что она окажется для Вас полезной,

а работа с ней будет для Вас приятной.

Программа WilDWooD Смета предназначена для расчета сметной стоимости работ по индексному методу.
Как правило, используется в основном в строительстве, но есть случаи использования программы и для расчета стоимости ремонта/монтажа аппаратуры и даже стоимости изготовления мебели "на заказ".
(Возможен расчёт и Ресурсным методом, в несколько нештатном режиме работы)

Сметы в данной версии программы представляют собой иерархические документы с одним уровнем вложенности: Разделы -> Работы в разделах.

В базовой поставке с программой включены основные (наиболее часто используемые) расценки справочников 1984-1991 года. Необходимые дополнительные справочники 1984-1991 года и ГЭСНр 2001 могут быть добавлены по отдельному договору.
О действующих в настоящее время индексах вы можете узнать в региональных центрах по ценообразованию в строительстве. Впрочем, никто не мешает Вам разрабатывать собственные ценники (главное, чтобы они были обоснованными) и рассчитывать стоимость работ в текущих ценах.

Данная программа распространяется про принципу ShareWare. То есть Вы в праве свободно скопировать и установить данный программный продукт на свой компьютер в ознакомительных целях. Приветствуется распространение данной программы в каталогах свободно распространяемого программного обеспечения, а так же среди друзей/коллег/знакомых.
Однако, WilDWooD Смета НЕ является БЕСПЛАТНЫМ программным продуктом. После ознакомления с программой Вы можете зарегистрировать свою копию для дальнейшего использования или должны деинсталлировать программу.

В случае обнаружения ошибок рекомендую:
1. от души выругаться
2. прошу описать:
· ситуацию (или действия), при которых она возникла
· что при этом выдала операционная система (сообщения, содержимое регистров...)

Если Вам необходима модифицированная версия программы, которая, например, будет производить расчет по другим методикам - свяжитесь с разработчиками.


Что нового в данной версии

версия 3.06
· - исправлено много старых ошибок (и, вероятно, добавлены новые)
· + добавлен экспорт документов (смет и актов) в XML формат.
· + разработаны конверторы для преобразованя XML документа в HTML.
· + добавлена поддержка mouse wheel (колесо прокрутки на мышке) в списках
· + добавлен импорт справочников из текстового файла с разделителями.
· / обновлён интерфейс программы (может кому понравится :)
· - убрана работа с архивными файлами

версия 3.05
· + добавлен экспорт в Microsoft Excel ( вернее в текстовый файл с табуляторами в качестве разделителей). Работает примитивно - но может кому-нибудь и пригодится. ;)
· + навигация по справочникам сделана более удобной (при повторном вводе работы список расценок открывается на том же справочнике)

версия 3.04
· + выпущена WilDWooD Смета Лайт (клон программы, не отягощённый справочниками)
· + добавлен заменяемый логотип в отчёты.

старые версии


Регистрация программы

Как зарегистрировать программу

Для регистрации программы вы должны послать запрос по е-mail с указанием номера Вашего компьютера из окна регистрации (меню: Утилиты->Регистрация или Ctrl-R).
(к примеру:)

На Ваш адрес будут высланы условия регистрации и, в случае вашего согласия, после потверждения факта оплаты регистрации - ключ регистрации.

После регистрации программа перестанет выдавать предупредительные надписи в отчётах и Вы сможете создавать сметы с количеством работ, превышающим 50.


Копирайт / Разработчики

Все права на данный продукт принадлежат
Радушинскому Валерию Феликсовичу, с которым можно связаться
по е-mail radushinsky@mail.ru или radushinsky@fromru.com
или ICQ:97675037

Запрещается декомпилировать, вносить изменения в программу и сопутствующую документацию (кроме случаев, предусмотренных действующим законодательством).

Продажа, модификация и пр. виды действий с данным прграммным продуктом без письменного разрешения автора преследуются по закону и могут привести к гражданской, уголовной и иным видам ответственности.
Никакая часть данного программного продукта не может быть использована для целей, отличных от её прямого назначения без письменного согласия автора.

WilDWooD Software Group
В настоящее время находимся в Санкт-Петербурге и специализируемся в разработке программного обеспечения. Будем рады сотрудничать.


Гарантии

Программа, а так же сопровождающая её база данных и документация поставляются без всяких гарантий (прямых или подразумеваемых) со стороны разработчика этой системы. То есть Вы можете использовать ее только на свой страх и риск.

Автор не принимает никакой ответственности за ошибки, упущения или ущерб (прямой или косвенный), вытекающий из использования информации содержащейся в этом документе или от использования программ и данных, которые могут сопровождать данный документ.
Ни в коем случае издатель и автор не должен быть ответственным за любые упущения выгоды или любой
другой материальный и прочий ущерб, реальный или предполагаемый, при прямом или косвенном использовании программы или данного документа.

Не гарантируется полная совместимость будущих версий программы с форматами данных текущей версии.
Если Вы при работе со старыми версиями программы разработали собственные расценки, (и их уже довольно много) а в новой версии они программой "не понимаются" - свяжитесь с разработчиками. Поможем :)

В свою очередь подтверждаю, что в программе НЕТ никаких "злонамеренных" алгоритмов и "троянских коней", которые могут привести к неработоспособности Вашей операционной системы или прикладных программ.

Если Вы не согласны с вышеуказанными ограничениями гарантии, просто прекратите использование данной программы.


ЧаВо

Часто Задаваемые Вопросы

В: Как заменить логотип на распечатках?
О: Ваш логотип в windows bitmap (.bmp) формате назовите logo.bmp и поместите в каталог программы вместо того. что находится там.

В: Как реализован экспорт в HTML формат? Могу ли я изменить формат документа?
О: На самом деле программа экспортирует сметы/акты в XML документ, который впоследствии преобразуется XSL трансформатором в HTML / АРПС формат. Чтобы изменить представление документа в HTML можете отредактировать соответствующие XSL файлы.
Или свяжитесь с автором программы, он-то уж точно поможет :)

В: При экспорте в EXCEL зацикливаются формулы. Что делать?
О: 1) можно изменить название сметы так, чтобы оно не содержало переводов строки
2) скопируйте HTML документ или требуемую его часть.

В: Как часто появляются новые версии программы?
О: Своевременно. Или несколько позже ;(
Так как данная программа не является основным видом моей деятельности, основная работа по её совершенствованию проходит в свободное время (т.е. когда нормальные люди спят, ночами Ж;-)
В случае обнаружения ошибок стараюсь их исправлять максимально оперативно.
В настоящее время разрабатывается совершенно новая (то есть с "нуля") сметная программа, использующая справочники ГЭСН и ГЭСНр и работающая по "ресурсному" методу.

В: Переустановил систему, и программа перестала работать. Что делать?
О: Связываться с разработчиками Если Вы её уже регистрировали - проблем с получением нового ключа не будет.

В: Можно ли в программе хранить много актов к одной смете?
О: Только если экспортированный документ (.TXT или .HTML) сохранить с другим именем в любом месте на Вашем компьютере. Каждая смета хранит "в себе" один акт (последний)


Общие правила

Всё управление в программе возможно с панели инструментов.
Если что не понятно по картинкам, читайте подсказки :)

Для наиболеее эффективной работы с программой рекомендуется пользоваться не только "мышкой", но и клавиатурой.

Приведем несколько правил работы, позволяющих значительно сэкономить Ваше драгоценное время:

· Большинству кнопок соответствуют "горячие" клавиши.

Например:
· Добавить элемент в список [image] = "Insert"
· Удалить элемент списка [image] = "Delete"
· Редактировать элемент [image] = "Enter"

· Попробуйте воспользоваться правой кнопкой мыши - во многих местах доступно контекстные меню, например:

Впрочем, есть их эквиваленты и на тулбаре:
· - вырезать
· - скопировать
· - вставить текст из буфера обмена


Начало работы

Начните работу с кнопки

Вы увидите несколько демонстрационных смет, выберите любую из них двойным кликом мыши или нажатием кнопки "Выбрать"

Попробуйте просмотреть содержимое данных в разделах и работах, и что при этом получается при выводе на печать.

Немного поиграв с готовыми сметами, давайте перейдём к Установкам программы.


Установки программы

Выберите в меню программы Утилиты->Установки или нажмите Alt-P
Перед Вами появится Окно

Заполните все реквизиты Вашей организации, которые будут подставляться по умолчанию во все вновь создаваемые сметы. Что, впрочем, не помешает их отредактировать "на месте" в каждой смете непосредственно.
То же самое действует и к данным, находящимся в остальных закладках в данном окне.


Создание сметы

Не думаю, что данная процедура у кого-нибудь вызывает сложности. И всё же...
В списке смет нажмите кнопку "Добавить" (или клавишу Insert)
Появится окно редактирования заголовка новой сметы:

Заполните соответствующие поля и нажмите клавишу "ОК".
После этого выберите данный заголовок в списке смет для добавления разделов и работ.


Список смет

Все кнопки на экране. Если создаёте новую смету - сначала добавьте её в список "Добавить", потом выберите для работы "Выбрать".


Редактирование сметы

После того, как заголовок сметы и основные коэффициенты были введены, перед Вами будет окно с незаполненной сметой, например:

Чтобы максимально быстро заполнить список работ предлагается следующий алгоритм.

1. Находясь на строке подсветки названия сметы, нажмите клавишу "Insert" или кнопку [image] на панели инструментов. В появившемся окне редактирования раздела введите название раздела. (Должен быть хотя бы один раздел!).

Если их будет несколько, повторите п.1.
Раздел добавляется только при активной подсветке Заголовка сметы

2. Нажмите конпку [image] или клавиши "Shift" и "Стрелка вправо" одновременно.
Разделы в смете при этом "развернутся" в дерево.

3. Стрелками "Вверх-Вниз" переместитесь на тот раздел, в который хотите добавить работы.

4. Нажмите клавишу "Insert", и приступите к заполнению работы.


Редактирование работы

Если Вы никогда в дальнейшем не планируете использовать добавляемую в смету работу, можете сразу заполнить соответствующие поля появившейся формы.

Всё же, я рекомендую начать заполнение работы с нажатия на кнопку "Справочник".
· кнопку "Справочник" можно нажимать не только мышью, но и просто нажав "пробел" или "Enter"

Как выбирать или добавлять расценки в справочник, смотрите в соответствующем разделе справки.

После того, как расценка выбрана и соответствующие поля перенесены из справочника в работу, введите количество работы. Впрочем, оставить данное количество равным НУЛЮ программа не позволит.

Если в соответствии с условиями работы требуется использовать повышающие/понижающие коэффициенты - измените значение коэффициента и нажмите на кнопку "? Счёт" или нажмите клавишу "F5". Если таких коэффициентов несколько - повторите указанную процедуру требуемое число раз. При этом стоимость единицы работы со всеми её составляющими будет изменяться каждый раз на соответствующий коэффициент.

Так, к примеру, разборка/демонтаж обычно проходит с коэффициентом 0,5 от сборки/установки. Ломать - это не строить ;) А вот работы повышенной опасности (например, под линией электропередач или около газо-нефте проводов) идут с коэффициентом 1.15, 1.20 и более.


Удаление сметы

Непонятно зачем, но это сделать тоже возможно.
Нажмите кнопку "Удалить" в списке смет.


Экспорт в Microsoft EXCEL

Если вдруг Вам это потребуется ....

1. Если смета ещё не открыта, выберите её в в списке смет
2. Воспользуйтесь соответствующим пунктом меню

На самом деле смета экспортируется в текстовый файл wsm_exp.txt с табуляторами в качестве разделителей, который впоследствии загружается в MS Excel / Lotus-123 или другую подобную программу.
Никакого форматирования документа при этом не производится. Кроме того, так как для ("красивой") печати заголовков введена возможность делать некоторые поля МНОГОСТРОЧНЫМИ, формулы в некоторых случаях могут "съезжать" и зацикливаться. Если дойдут руки - подправлю.

Чтобы избежать подобного эффекта, просто скопируйте табличку из полученного HTML документа ;) а фрмулы подставить и самостоятельно сможете.

Более сложный экспорт с использованием OLE Automation/DDE реализован в профессиональной версии программы.


Выбор расценки из справочника

В окне заполнения работы нажмите на кнопку

мышью, либо просто нажмите "пробел" (так иногда быстрее).

Перед Вами появится список расценок.

Если Вы уже знаете, из какого раздела справочника необходимо достать расценку, просто наберите первые несколько символов из шифра расценок. Автоматически курсор переместится на нужную запись (или ближайшую к ней).

Однако, если фокус ввода находится в данном поле (к примеру, зачем-то Вы туда поместили курсор нажатием левой кнопки мыши :) вам придется нажать ещё и клавишу "Tab".
Чтобы отредактировать значения в поле поиска, можете использовать клавишу "<-Backspase".

Если хотите ограничиться поиском в пределах единственного справочника, перейдите в соответствующую закладку и выберите требуемый справочник.

Если Вы не знаете ни шифра ни справочника, можете воспользоваться фильтрацией базы по содержимому.

Кнопка "Фильтр" вызовет диалог построителя запросов по образцу. Такой подход оправдан, если Вы планируете в будущем неоднократно фильтровать базу по определённому критерию (или многим)

гораздо быстрее перейти на закладку "по работам", и набрать там искомое слово, например "кросс", и нажать на клавишу "Tab".
Все записи будут отфильтрованы, и на экране высветятся только те, котрые содержат искомое слово. Например:

Собственно Выбор найденной расценки производится либо двойным нажатием левой кнопки мыши, либо кнопкой

Если искомой расценки не оказалось в справочнике - можете добавить её туда самостоятельно.


Фильтрация

Возможно сохранение запросов для будущей работы.
Для этого
· сначала задайте имя запроса.
· на вкладке "параметры запроса" введите условия фильтрации.
· нажмите кнопку "Сохранить"

Если Вы хотите загрузить уже существующий запрос - выберите его в списке и нажмите кнопку "Загрузить"

Если Вы хотите, чтобы загруженный фильтр прекратил отбор данных - нажмите кнопку "Очистить"


Импорт расценок

Вы можете импортировать расценки из текстового файла с разделителями в .CSV формате.
каждый столбец импортируемого справочника должен быть обрамлён кавычками.
Строки разделяются символом перевода строки.

пример строк импортируемого файла :

"26";"Р15-22";"ремонт чебурашек";"10 чеб.";"100";"80";"14";"3";
"26";"Р15-23";"подбивка каблука";"1 каблук.";"40";"15";"5";"";

"справочник";"шифр";"наименование";"ед.измерения";"стоим.общ";"на зар.плату";"эмм";"з.пл.маш.";

могут быть и другие поля, они просто не будут восприниматься.

Внимание! Если поле не содержит данных, оно всё равно должно присутствовать (пустое "";)


WilDWooD Sofrware Group
неформальная группа программистов, вышедшая из дикого северного леса
(где-то в районе космодрома "Плесецк" :)


Акты выполненных работ

В текущей смете нажмите кнопку

Появится соответствующее окно, в котором текущее количество выполненных работ может быть изменено.
Если к актам относитест формально, и требуется, к примеру, в конце каждого периода представлять отчётность о выполнении какого-то числа процентов работы - выберите соответствующий пункт в расширившемся меню "Акт"

после чего акт приобретёт соответствующий вид.

Вывести на печать можно или соотв. кнопками в левом верхнем углу окна, или через меню "Файл"->"Экспорт"

Работы с нулевым количеством выполненной работы в акте не отображаются!.